Centos7安装新的高版本的ruby

260次阅读
没有评论

CentOS 7 用 yum install ruby 默认安装的 Ruby 版本是 2.0。

Centos7 安装新的高版本的 ruby

要在 CentOS 7 上安装最新版本的 Ruby,您可以按照以下步骤进行操作:

  1. 更新系统:sudo yum update
  2. 安装必要的依赖项:sudo yum install -y curl git-core gcc-c++ patch readline readline-devel zlib zlib-devel libyaml-devel libffi-devel openssl-devel make bzip2 autoconf automake libtool bison
  3. 安装 rbenv(用于管理 Ruby 版本):git clone https://github.com/rbenv/rbenv.git ~/.rbenv echo 'export PATH="$HOME/.rbenv/bin:$PATH"'>> ~/.bashrc echo'eval "$(rbenv init -)"' >> ~/.bashrc source ~/.bashrc
  4. 安装 ruby-build 插件(用于安装不同版本的 Ruby):git clone https://github.com/rbenv/ruby-build.git ~/.rbenv/plugins/ruby-build echo 'export PATH="$HOME/.rbenv/plugins/ruby-build/bin:$PATH"' >> ~/.bashrc source ~/.bashrc
  5. 安装 OpenSSL:sudo yum install -y openssl-devel
  6. 安装最新版的 Ruby:rbenv install --list # 列出可用的 Ruby 版本 rbenv install <version> # 安装指定的 Ruby 版本,例如:rbenv install 3.0.2
  7. 设置全局默认的 Ruby 版本:rbenv global <version> # 设置全局默认的 Ruby 版本,例如:rbenv global 3.0.2
  8. 验证安装:ruby --version # 检查 Ruby 版本 gem --version # 检查 gem(Ruby 包管理器)版本

现在,您已经成功安装了最新版本的 Ruby。请根据您的需要安装所需的 Ruby 版本,并设置为默认版本。

正文完
 1
板面杂货铺
版权声明:本站原创文章,由 板面杂货铺 于2023-09-08发表,共计923字。
转载说明:除特殊说明外本站文章皆由CC-4.0协议发布,转载请注明出处。
评论(没有评论)